THE PEAVEY T-40 BASS ENTHUSIASTS FORUM

A FORUM FOR PEAVEY T-40 BASS ENTHUSIASTS
 
HomeFAQRegisterLog in

Share | 
 

 Bridge Pickup issues

View previous topic View next topic Go down 
AuthorMessage
JohnnyThreat

avatar

Posts : 17
Join date : 2012-01-12
Age : 24
Location : Baltimore, MD

PostSubject: Bridge Pickup issues   Mon Jan 23, 2012 1:53 pm

It all started on Christmas...My girlfriend got me a black 1984 T-40. Gorgeous, played well, the whole 9. But when the phase switch was in the up position, it cut out. After doodling with it for awhile, I found out that it wasn't' cutting out, it was just really quiet, think practice volume when my practice amp was at 10, whereas everything else sounded fine at about 2 or 3. when the phase switch was down, the bridge pickup sounded normal. The problem is that I can't play both pickups at the same time, because the out of phase sound is junk. So now all I can do is set the phase switch down, and play each pickup solo. Now, I still have tons of tones, but I can't play both pickups in phase, which I hear is arguably the bass' best sound. So, after having the tech at music go round switch out both the 3 way, and phase switches, and not finding any problems whatsoever with the wiring, I still have the problem. In other words, I'm out 40 bucks for no results. So I'm turning to you, the fine folks of the T-40 forum, with far more knowledge than I, to diagnose this problem. Is it the pickup? That's my biggest fear, since I can't find a single replacement anywhere.

BQ: Do the t-40 and T-60 use the same pickups? They look the same in pictures, but I've never seen a t-60 in person to judge by scale, and I figure that chances are, they are at last wound differently, even if they are drop in replacements for each other. That was just a nagging question I've had since becoming enamored with the 70's and 80's Peavey instruments.
Back to top Go down
View user profile
Frank N. Peavey

avatar

Posts : 699
Join date : 2007-11-27
Age : 51
Location : Home of the Choo Choo

PostSubject: Re: Bridge Pickup issues   Wed Jan 25, 2012 7:31 pm

There have been some bad pickups out there. Chip has noticed a manufacturing change done to the pickups after he left to go to Fender. Seems that the new "improved" process killed one of the coils in the pickup when the chrome covers were attached.

The T-60 and T-40 use different sized pickups, but of the same design.

Pickups do show up on eBay from time to time. I don't have any spares at the moment.

_________________
Tony
ITOC #05-00013

4 T-60s,  T-63, T-15, Generation Standard, Hydra, Mantis LT, Milestone, Mystic, Odyssey, Patriot, Patriot tremolo, Predator, Raptor, Razer, Reactor, 3 Rockmasters, Tracer, Backstage, Bandit, VSS 20, Vypyr 30, Vypyr VIP-1.
Back to top Go down
View user profile
Knappyheadedmutha



Posts : 9
Join date : 2012-04-01

PostSubject: Re: Bridge Pickup issues   Thu Apr 12, 2012 8:41 pm

Set up pups right now on ebay..
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Bridge Pickup issues   

Back to top Go down
 
Bridge Pickup issues
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Crikey! Back issues
» WTB: GMC/Chevy pickup, $5000
» Technic Bridge Layer
» Real weird issues with 94 LT1 Roadmaster sedan
» Head Gasket Issues RR, RRC, D1 & D2

Permissions in this forum:You cannot reply to topics in this forum
THE PEAVEY T-40 BASS ENTHUSIASTS FORUM :: T-40 DISCUSSION :: PEAVEY T-40 DISCUSSION-
Jump to: